# Do not modify this file! It was generated by ‘nixos-generate-config’
|
# and may be overwritten by future invocations. Please make changes
|
# to /etc/nixos/configuration.nix instead.
|
{ config, lib, pkgs, modulesPath, ... }:
|
|
{
|
imports =
|
[ (modulesPath + "/installer/scan/not-detected.nix")
|
];
|
|
boot.initrd.availableKernelModules = [ ];
|
boot.initrd.kernelModules = [ ];
|
boot.kernelModules = [ ];
|
boot.extraModulePackages = [ ];
|
|
fileSystems."/" =
|
{ device = "/dev/disk/by-uuid/b9c5365e-6b8c-414d-9bb0-d6951a7aa6dd";
|
fsType = "btrfs";
|
options = [ "subvol=@" "compress=zstd" ];
|
};
|
|
fileSystems."/boot" =
|
{ device = "/dev/disk/by-uuid/37DD-1C0B";
|
fsType = "vfat";
|
options = [ "fmask=0077" "dmask=0077" ];
|
};
|
|
boot.zfs.extraPools = [ "pool" ];
|
|
# fileSystems."/var/lib/docker" =
|
# { device = "/pool/docker/var";
|
# options = [ "bind" ];
|
# };
|
|
swapDevices = [ ];
|
|
services.btrfs = {
|
autoScrub = {
|
enable = true;
|
interval = "weekly";
|
};
|
};
|
|
services.zfs = {
|
autoScrub.enable = true;
|
trim.enable = true;
|
};
|
|
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
# (the default) this is the recommended approach. When using systemd-networkd it's
|
# still possible to use this option, but it's recommended to use it in conjunction
|
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
networking.useDHCP = lib.mkDefault true;
|
# networking.interfaces.wlan0.useDHCP = lib.mkDefault true;
|
|
nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
|
}
|